Reply
Trusted Contributor
Trusted Contributor

Re: G3616 Gas engine High oil temperature

The engine oil is cooled by the auxiliary (SCAC) cooling system, which also cools the inlet air to the cylinders.  If the SCAC temperature regulators are not working correctly, then you would also probably have high inlet air temps.  If the oil temp regulators are not working correctly, then you will probably only have oil temperature issues.  If the oil coolers are plugged then you will most likely have an oil temperature issue. You will have to measure what the SCAC coolant temp is coming back from the cooler to the engine.  This will tell you if the cooler section is performing as it should.  If the cooler is working, then the oil temp issue is probably on the engine; oil cooler or oil temp reguators.

This is where I would start looking.

 

Best Regards,

Al Hunt

Visitor

Re: G3616 Gas engine High oil temperature

Hello, Any body can help to resolve high engine oil temperature shutdown is coming in peek summer.We did the following 1.replaced the engine oil temperature sensor 2.Replaced the engine oil temperature regulator Is it required to replace the auxiliary water temperature regulator? The unit is running almost 50000hrs. Anybody can assist me to do what next?
Visitor

Re: G3616 Gas engine High oil temperature

Hi,
The unit is running on 33000hrs.
We have an oil coolers failure issue on these engine.so the top oil cooler is replaced on 3 months back and bottom cooler replaced on 9 month back.
What you mean to measure both lube oil and cooling water in and out ?
Super Contributor

Re: G3616 Gas engine High oil temperature

Have you done any checks to the oil cooler circuit?  Measuring both the lube oil and cooling water in and out may help determine if you a problem there.

 

How many hours on the unit?

 

How long since the oil cooler was serviced?

 

MikeL.

Visitor
Accepted Solution

G3616 Gas engine High oil temperature

Hello,

Any body can help to resolve high engine oil temperature shutdown is coming sometimes.We did the following

1.replaced the engien oil  temperature sensor

2.Replaced the engien oil temperature regulator

3 Replaced the engine harness,

4.Replaced the ECM with another one.

Still the problem is not solved,nornally engine is running smooth,tripping some times,may be once  in a day or 2days one time like that.

Anybody can assist me to do what next?