Reply
Highlighted
Super Contributor

Re: Highway use 3406E - breaking up over 1800rpm

This is an unusual problem. Was the camshaft replaced? Part number? Has the timing been calibrated? What is the part number of the software in the engine ECM?
Visitor

Re: Highway use 3406E - breaking up over 1800rpm

We are using the correct gauge to adj the injectors.  We had the truck to CAT and had the truck disconected from the ECM, there are no lights on and codes in the ECM.  This is not just a "skip" it is breaking up both with and without a load, above 1600 under a load when over 150 degrese.  When not under a load when left at high RPMs it misses at 1800 and above when over 150. Please feel free to call me at 540-998-8800.

Super Contributor

Re: Highway use 3406E - breaking up over 1800rpm

Have you checked the fuel return hose for restriction? It's common for the return line to be constricted after several years. Are you using the 9U7227 gauge to adjust the injectors? Do you back off the engine brake adjustments before adjusting the valve lash? Does the check engine light come on? FYI It is normal for the engine to "skip" at high idle, no load.
Visitor

Re: Highway use 3406E - breaking up over 1800rpm

At one time while throtle was wide open, when the fan was manually engaged it broke up and when the fan was disengaged it stopped.  It does not break up until the engine reaches 150 degrees.  Only with wide open throtle while in garage.  When under a load (on the road) it breaks up at 1600rpm and above on a hard pull.  

Visitor

Re: Highway use 3406E - breaking up over 1800rpm

injector kit # 10r8500

engine serial # 2ws05800

 

we have just inspected the front gears and replaced the injectors 3 times.  No change in symptoms.  

Super Contributor

Re: Highway use 3406E - breaking up over 1800rpm

Is the "breaking up" at no load? What is the part number of the injectors? What is the engine serial number?
Visitor

Highway use 3406E - breaking up over 1800rpm

I am working on a 3406E cat in a 1999 KW w900L.  over 1million miles on truck.  unknown mileage on rebuild.  

 

This truck was breaking up over 1800rpm.  It went to CAT, they put it on their computer and they said it was probably the injectors or the injector wiring harness.  I replaced both and it still has the problem.  I replaced the engine wiring harness, ECM, cyl head, all sensors, all fuel lines, fuel filter housing and filter.  Visually inspected the Crank shaft.  90 to 100 lbs of fuel pressure.  Ran a clear line off the fuel return line, no air in line. Took it back to CAT, they disconnected truck from ECM, still has the problem.   

 

My local CAT dealer in Roanoke VA has been VERY helpfull and has said that I have done all they can think to do.  Need help.