Reply
Visitor

Re: 246C Skid Steer Fuel Issue, I Think...

Thank you for replying
I have had my machine for 10 years and it is like a part of me, I'm a owner operator and I fix it on my own if possible,if you can update me to the solution I would greatly appreciate it and I'm happy I'm diagnosing it correctly from my end , I saw all the work you put into the wrong system and don't have the time to guess too long and the Cat dealership is too expensive to rely on
Thank you very much it eases the stress a little
Jason Rawn
New member

Re: 246C Skid Steer Fuel Issue, I Think...

It seems it is a hydraulic valve issue. The check port at the bottom of the main valve stack was running 2700 psi at idle and then got up to 5000 psi before the motor can't take any more and stalls out. I have a hydraulic repair shop going through the stack this week. I would suggest checking pressure at those check valves to help isolate where your issue is. It's is definitely not motor related.
Visitor

Re: 246C Skid Steer Fuel Issue, I Think...

I believe it is a hydraulic valve issue , I'm trying to isolate the issue today

Visitor

Re: 246C Skid Steer Fuel Issue, I Think...

Hi,

im having the same problem, I wondering if you were able to resolve your problem and any advice ?

Highlighted
New member

246C Skid Steer Fuel Issue, I Think...

Have a 2011 Cat 246C skid steer that is running rough at lower rpm and will not accelerate above about 1200 rpm, if the throttle is pushed past that point it boggs down and acts as if it ran out of fuel. What confuses me is that the machine will go up to 2500 rpm if the lift cylinders or the bucket cylinders are in motion, the wheel movement doesn't affect it, and as soon as the cylinders stop moving it studders and goes back to about 600 rpm and almost dies.

 

What I have done:

New primer pump, fuel/water separator filter, had the injection pump rebuilt and tested, replaced fuel lines, bled the lines going into the injectors, verified the fuel pressure from the tank to the injector pump was running between 5-7 psi.

 

The machine runs somewhat rough at idle and produces more smoke than normal until I bleed the injection lines, then it runs much smoother. Fuel is new clean fuel, as I said new filter. All lines are clear and supplying correct fuel pressure. What am I missing? Any ideas?