Reply
New member

Re: Front Loader Failure while using backhoe on 430D

Found the issue last night. The problem was the ride stabilization control that tries to stabilize the cab by moving the front bucket around. As the backhoe would bounce the cab, the front bucket would automatically try adjusting. Flipped the switch and no more problems.

New member

Front Loader Failure while using backhoe on 430D

I have a new (to me) 430D with 7000 hours on it. After polishing it till it sparkled, I was passing a family trying to dig out some juniper bushes and offered to give them a hand. It was the first thing I had done other than give the kids a ride in the bucket and raised the front end up using the front bucket, then the stabilizers and started to work.

 

Everything was going great, then suddenly, the front end dropped on me while I was operating the backhoe. I raised it back up again, a few seconds later it dropped again. I was able to finish luckily since they were wimpy bushes compared to the might of my new (to me) backhoe, but then trying to swing the backhoe side to side to smooth the dirt a little I noticed that there was almost no power at all in the side to side motions. It did fine when raised up, but if it was trying to push more than 2-3 shovel full worth of dirt, it couldn't move.

 

I hvaen't noticed any weakness anywhere else. I checked fluid levels, which seem excellent, and wasn't sure what I could the issue was. I haven't gotten a trailer yet, so I would love to see if I could fix it myself on site, but need to get a few ideas.