Reply
Highlighted
Visitor

Re: Unexpected shut down without diagnostic code

Thanks Mikel for replaying.

This unit is far away north and I am planning to go soon to see what is going on.The unit is standby and it is 2MW .I can check voltage supply .Could you tell me please what would happen if those voltages stop supplying for a moment.What is interesting we have EMCP 3 shut down alarms on HMI even when engine is not running at all.Yes RTD module communicate on CANBUS.

Would you give me some inputs how unit would shut down if we lost CANBUS comm.

I havent seen any CANBUS failing but I have seen many MODBUS failings that we use to comunicateEMCP3  to PLC toPower meter and generator prot. relay.I can send you HMI alarm history for last 4-5 months if you would be interested for looking on them. I could send you CAT ET product status report too.

This unit is running certain amount of time and shutting down from some reason.I can run this unit with other station in parallel in DROOP mode but unfortunetely I can put just 300KW on it because of low load.I know it will be painfull to find the problem.Any help would be greatly appreciated.

Super Contributor

Re: Unexpected shut down without diagnostic code

Well, could be a number of things, what would be helpful is some more details on your unit, like serial number, application (prime, standby, etc.). Because you have what appears to be three seperate devices, EMCP3, digital pyrometer and the engine ECM all having faults, it is likely something common to the three.

 

So first thing to check would be the DC power going to the unit, make sure connections are good. Do you have a battery charger? If so, have you checked the DC power for an AC ripple? Have you verified that positive to negative and postive to ground are close and that negative to ground is a very low value?

 

Another possible common link could be a comms problem, does the pyrometer communicate on the CANBUS? If so and of the DC power checks out it may be a problem related to the CANBUS J1939 network, check connections and make sure the terminating resistors are in the correct places in the netwrok wiring.

 

MikeL

 

 

Visitor

Unexpected shut down without diagnostic code

I have 3516 engine and there is unexpected shut down from time to time.There is no any diagnostic code in EMCP3.I could see a lot of cylinder pyrometer failings but they are giving alarms not shut downs.At HMI I can see engine shut down command, breaker trip command at same time and engine stop 6 seconds later without cooling down.I found some modbus fails too.

Hard to troubleshoot without diagnostic code.Just wondering what would happen if EMCP lost DC supply for short period of time.Is there any auxiliary DC supply in that case to shut engine down?Did anybody have any case that EMCP issues shut down without diagnostic code and what could be that?

Ps: Engine has only 470 hrs