Reply
Highlighted
New member

Re: Cat C15 MXS single turbo conversion issue

He doesn’t have a computer or a smartphone sorry guys I was just trying to help him out
New member

Re: Cat C15 MXS single turbo conversion issue

I’m asking for a friend, just copied and pasted this for him, he didn’t know he was altering emissions
Super Contributor

Re: Cat C15 MXS single turbo conversion issue

Posting on a Cat hosted web site that you made illegal modifications to the emissions system on a Cat on-highway truck engine. I believe the fine is $25000.
New member
Accepted Solution

Cat C15 MXS single turbo conversion issue

Hey guys I'm new here just looking for some help here, i have a 06 peterbilt 379 that has a mxs c15 and i just did a single turbo conversion, i used a borg warner 177148 turbo and a 6nz manifold, i got everything together and it starts and runs Good, has about 80 psi of fuel pressure, the issue I'm having is it only wants to make 20 psi of boost, i had the iva delete done and i backed all of those off and plugged the oil galley that feeds them, also unhooked the iva oil pressure sending unit, i have no check engine lights at all, anyhow it is turned up to about 580-600 now and i know 20 psi boost is to little for that and i have plugged the wastegate, checked cac and boots for leaks, it fuels hard till it hits 20 psi and then just stops fueling, BUT I was driving it around and shifted into the next gear and all of a sudden it had full fuel and made about 38-40 psi in boost but then i shifted again and back to 20 psi it went and i can't get it to full fuel any more than that one time, side note i took the resistors out of the boost wire that i had in there before any help is appreciated, some people have told me to try boost sensors it just threw me in a loop when it did full fuel that one time and made 40 psi any help is so so appreciated