Reply
Highlighted
New member

Re: C13 Engine oil pressure disipating

Also get an SOS oil analysis to see if you have excess wear metals in the oil and an indication of what is wearing.

Contributor

Re: C13 Engine oil pressure disipating

[ Edited ]

if your mechanical oil pressure gauge shows low engine oil pressure, and no noticeable abnormal noise or smoke, you can cut open your oil filter and look if there is metal particules, you can also, as a simple and quick check, remove the valves cover to verify if there is lubricating oil supplied to the valves mechanism.

 

Ultimately, you may have to drop the oil pan and ckeck for sign of wear on the cranshaft bearings and the crankshaft itself, you will in the same be able to verify if the piston cooling nozzles are in place

New member

Re: C13 Engine oil pressure disipating

Several things can cause low oil pressure, piston cooling jets that have come loose, high pressure relief valve or oil bypass valve becoming stuck, or even loose plugs on the can shaft. If it is a reman engine it’s best to take your engine to a certified caterpillar engine shop.
New member

Re: C13 Engine oil pressure disipating

Have you cut open the filter to see if it is plugging with something prematurely?

New member

C13 Engine oil pressure disipating

Hi everyone. Hopefully someone will be able to help me. I have a C13 engine that we built into a Hyundai 800 R excavator. The engine had been running fine for a number of months now. Two weeks ago it started dropping engine oil pressure. We have changed the oil filter housing with the 3 relief valve inside. Oil pressure then returned to normal. Last week the problem started all over again. Everytime we change the engine oil filter, pressure returns to normal and slowly drops to where the machine cuts out. We have fitted a manual pressure guage to the engine as we thought the oil pressure sensor might be the problem, but it too shows the oil pressure dropping. The oil pressure sensor is not the problem. We opened the Scavanger pump but everything is fine. The engine has been overhauled before we fitted it to the machine. We have also fitted a new turbo charger to the engine about a month ago due to a failure.

 

Is there anything else we can have a look at as I am not that knowledgeable on Cat engines.