Reply
Highlighted
New member

Re: High NOx

It is the 1500 RPM @ 1.95 MW. I am due for maintenance on that unit. Top-End, Ross, mains, and re-ring. I would rather just put in packs in. I have replaced all the plugs and transformers as well. I found that if I take it out of 4-20mA and manual adjust the btu’s from 420 (give or take due to quality change) up to 580 I can get the NOx and the CO due to normal levels.
Contributor

Re: High NOx

I had NOx about (5000-7000), the problem was in hight voltage cable broken, after ignit transformer to spark (it was new spare))

Contributor

Re: High NOx

what MW unit is this? 1200rpm 1.6MW or the 1500rpm 1.95mw, the 1.95mw unit we operate has a hard time achiving .5gram nox at full load, even when fresh off an inframe.  Seems like the scaling for e gain is to far rich and we run out of adjustment like you are experiencing..  the 1.6mw units we have next to the 1.95mw never have an issue acheiving .5grams nox.  Typically when piston packs are heavly worn or siloxanes deposits in the combustion chambers are heavy the Co and nox increase.  Also all it takes one bad spark plug or ign transformer to cause a significant increase in Nox due to a misfire. 

New member

High NOx

Good afternoon all. I’m running 3520c gensets. This is a Landfill application. Recently on one of my unit my NOx has gone very high. I yesterday I did find a leaking head gasket and replaced it. I also put a new set of CAT Chamber plus in and adjusted all the bridges and relashed all the valves. My TSOV’s, temps, throttle position, and TBAV, are all running where they should be. My timing is 30.5 egain is at 86% and I am running in 4-20mA configuration mode. If anyone can give me a suggestion on where to look next, I would greatly appreciate it.