New member MG
New member

Re: Flashing of Color MPD.

hello all, my first post here. 


I have a situation in C32 Marine propulsion with CMPD. A new flash file is required and at the moment the CMPD is showing only Windows CE screen. I tried flashing the unit with CAT ET 2015C and as it goes on I get to the point when the flshing is completed (get info on ET 100% successful) the unit goes black and again the WIndows CE screen comes up again.


Any suggestions?

Trusted Contributor

Re: Flashing of Color MPD.

Problem found.


according the drawing there was a termination resistor(120 Ohm) in the line, which there wasnt.

It looked like one but is was just a cut off connection.

2 resistors installed on both engines and after about 30 minutes the flash was completed without problems.


thanks for taking your time and have a look in it.

Super Contributor

Re: Flashing of Color MPD.

Latest firmware for the CA3 is 1.23.54. This is included with the latest CA3 tool kit.
Trusted Contributor

Re: Flashing of Color MPD.

Flashing the CMPD can be with USB or Cat Comm Adapter. The USB part number is 318-8840.  You will also need speical Microsoft software for USB flashing depending on the PC operating system.  For WindowsXP download ActiveSync.  For Windows7 you will need Windows Mobile Device Center.  Flashing with USB take about 3-4 minutes.  Flashing with CA3 takes about 30 minutes.


If you are flashing with CA3 make sure you have updated the CatET sofware to at least 2013B and update the firmware on the CA3 to latest file.  Updating these two files have helped in my flashing.

Trusted Contributor

Flashing of Color MPD.

goodmorning guys,


i was wondering who could help me out.

i have been searching for a partnumber everywhere but cant find it.

we have 2 brand new CMPD(355-....) panels for a client of ours, they are going to be used on 2 older 3412E`s after the engine vision short circuited.


when i prepare for flasing and select the flashfile-361-5006-(18mb) it tells me to flash through USB cable?????

if been trying to find the partnumber in SIS but i cant find it. 

If i flash it through the normal ways, it seizes at various points of progress.

i tried various Com adapters 2&3 and various versions of ET. 

no succes sometimes i get 15% then 20% next 5%, and then flash procedure seizes.


any thoughts??


thanks patrick